[an error occurred while processing this directive] [an error occurred while processing this directive]

Downloads

Even though Opus is now standardized by the IETF, this Opus implementation will keep improving in the future. Of course, all future versions will still be fully compliant with the Opus IETF specification. See the development page for the latest development information.

Mozilla logo

Development binary builds

In addition to support in Firefox, Mozilla provides binary builds of Opus utilities.
Package Version Platform Download link Size
opus-tools 0.1.9 Windows opus-tools-0.1.9-win32.zip 403KiB
Mac OS X opus-tools-0.1.9-macos.tar.gz 399KiB
Source opus-tools-0.1.9.tar.gz 376KiB
Opus-tools provides command-line utilities to encode, inspect, and decode .opus files.
opusfile 0.6 Windows opusfile-0.6-win32.zip 1.5MiB
Source opusfile-0.6.tar.gz 428KiB
Opusfile provides application developers with a high-level API for decoding and seeking in .opus files. DLLs for the required libraries libogg 1.3.2, libopus 1.1 and openssl, are also included in the binary package.

Source code

Latest stable release

libopus 1.1

Opus 1.1 includes:

These improvements are explained in more details in Monty's demo (updated from the 1.1 beta demo).

libopus 1.0.3

Opus 1.0.3 includes a backport of the new 1.1 surround API. Aside from that, it includes fixes for a few minor glitches during mode switching, some minor fixed-point fixes, and fixes a regression in the FEC code introduced in 1.0.2.

Latest development releases

libopus 1.1.1-beta

This is a beta release for the upcoming 1.1.1 version. Compared to 1.1, it mostly includes optimizations for x86, MIPS and ARM.

opus-tools 0.1.9

This release adds support for 32-bit floating point WAV output and fixes a number of minor issues.

opusfile 0.6

The opusfile library provides seeking, decode, and playback of Opus streams in the Ogg container (.opus files) including over http(s) on posix and windows systems.

Changes since the v0.5 release:

Some of these bugs kept basic functionality of the APIs from working at all, so we recommend all users upgrade.

Older/Historic Releases

[an error occurred while processing this directive]